Admin portal down due to a billing misconfiguration with our cloud provider
Incident Report for Hypercare Inc.
Resolved
This incident has been resolved.
Posted 5 months ago. May 09, 2019 - 17:34 EDT
Identified
Service will be restored shortly once the billing misconfiguration has been fixed. It is not a technical issue nor the servers are down.
Posted 5 months ago. May 09, 2019 - 15:08 EDT
This incident affected: Administration Controls (Admin Panel).