Resolved incident around inability to login post pin lock
Incident Report for Hypercare
Resolved
Two days ago, a few of our users unfortunately could not get past the pin lock screen on iPhone to access their messages. Users who re-installed the app unfortunately did not result in addressing the issue. The only way support could have addressed it was ask the user to forget their pin which resulted in a log out. prior Given the limited amount of affected users, it was extremely difficult to pin down the root cause. After going through numerous edge cases, we were able to narrow down to authentication which was resulting in a bug where users would be presented with a infinite loading animation until timeout. We have addressed the issue with a patch from the backend that goes into affect immediately and will address the issue until the full fix is released from client in the next week. We apologize for this incident. This incident was not filed as we were unsure of the scale and the validity of the incident given the small amount of affected users. Given the affected user list was slowly growing, we quickly realize this was a critical issue and resolved it within 24 hours of realization.
Posted Nov 13, 2019 - 00:47 EST
This incident affected: Canadian Region (Login and Single Sign On (Canadian Region)).