Certificate expired for web app
Incident Report for Hypercare Inc.
Resolved
This incident has been resolved.
Posted 19 days ago. Aug 30, 2019 - 03:19 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted 19 days ago. Aug 30, 2019 - 02:53 UTC
This incident affected: Web Messaging Portal.